[gridengine users] sge_execd installation problem

Reuti reuti at staff.uni-marburg.de
Fri May 3 10:46:32 UTC 2013


Hi,

Am 03.05.2013 um 09:51 schrieb Jacques Foucry:

> I'm still trying to install a SGE cluster.
> 
> I have a host (named qmaster) install as a qmaster (using the install_qmaster script).
> 
> It runs
> # ps aux | grep sge
> sge       4582  0.0  0.4 146888  4500 ?        Sl   Apr29   0:50 /usr/local/sge/bin/linux-x64/sge_qmaster
> 
> And seems to be ready to commincate:
> 
> # netstat -tap | grep qmaster
> tcp        0      0 *:sge_qmaster           *:*                  LISTEN      4582/sge_qmaster
> 
> # bin/linux-x64/qconf -sh
> qmaster.ns42.fr
> sge0.ns42.fr
> sge1.ns42.fr
> 
> 
> I try to make sge0 a execd host. So I use the install_execd script. It fail tell me that it cannot find a qmaster.

This sounds like the $SGE_ROOT isn't shared between the nodes, and so it can't use $SGE_ROOT/default/common/act_qmaster to get its name. It's either necessary to share at least the "common" directory, or copy this information by any means to all nodes:

http://arc.liv.ac.uk/SGE/howto/nfsreduce.html

-- Reuti


> 
> How can I specify my remote qmaster?
> 
> Thanks in advance,
> Jacques
> 
> -- 
> Jacques Foucry
> *NOVΛSPARKS *
> IT Manager
> Tel : +33 (0)1 42 68 12 61
> jacques.foucry at novasparks.com
> _______________________________________________
> users mailing list
> users at gridengine.org
> https://gridengine.org/mailman/listinfo/users
> 





More information about the users mailing list