[gridengine users] Hosts not fully used with fill up

Rafael Arco Arredondo rafaarco at ugr.es
Thu Sep 18 12:52:22 UTC 2014


Hi,

The hosts are free before running the jobs and are all identical in
terms of available resources.

Looking a bit deeper into the problem, it seems that sometimes jobs
requesting only 8 slots are executed on the nodes, overriding the check
in the prolog (which says the number of slots has to be multiple of 16).
It's like the prolog sometimes wasn't executed...

El jue, 18-09-2014 a las 14:01 +0200, Winkler, Ursula
(ursula.winkler at uni-graz.at) escribió:
> Hi Rafa,
> 
>  Are the jobs scheduled on hosts where already other jobs are running (so that only 8 slots are used on some hosts)? Or are all hosts free? Have all nodes the same resources (i.e. slots, memory,...?) configured?
> 
> C., U.
> 
> -----Ursprüngliche Nachricht-----
> Von: Rafael Arco Arredondo [mailto:rafaarco at ugr.es] 
> Gesendet: Donnerstag, 18. September 2014 12:23
> An: Winkler, Ursula (ursula.winkler at uni-graz.at)
> Cc: users at gridengine.org
> Betreff: Re: AW: [gridengine users] Hosts not fully used with fill up
> 
> Thanks Ursula for your reply, but we need a parallel environment for more than one node (we are using it with MPI). Sorry if I wasn't clear enough.
> 
> I give you an example. We have hosts with 16 slots. Now the user requests 32 slots for a job, but instead of allocating slots on two nodes, sometimes four nodes are used, each with 8 slots. We don't know why this is happening, but it didn't happen with 6.2 with a similar configuration.
> 
> Cheers,
> 
> Rafa
> 
> El jue, 18-09-2014 a las 12:11 +0200, Winkler, Ursula
> (ursula.winkler at uni-graz.at) escribió:
> > Hi Rafa,
> > 
> > for such purposes we have configured a separate Parallel Environment with "allocation_rule" "$pe_slots" (instead of "$fill_up"). Jobs scheduled with this rule can run ONLY on one host.
> > 
> > Regards,
> > Usula
> > 
> > -----Ursprüngliche Nachricht-----
> > Von: users-bounces at gridengine.org 
> > [mailto:users-bounces at gridengine.org] Im Auftrag von Rafael Arco 
> > Arredondo
> > Gesendet: Donnerstag, 18. September 2014 09:44
> > An: users at gridengine.org
> > Betreff: [gridengine users] Hosts not fully used with fill up
> > 
> > Hello everyone,
> > 
> > We are having an issue with the parallel environments and the allocation of slots with the fill up policy.
> > 
> > Although we have configured the resource quotas of the queues not to use more than the number of slots the machine have and we control in the prolog that the jobs be submitted with a number of slots multiple of the number of physical processors, we are observing that sometimes, the slots of a job are split into several nodes, when they should be running in only one node.
> > 
> > We are using Open Grid Scheduler 2011.11p1. This didn't happen in SGE 6.2.
> > 
> > Has anyone experienced the same situation? Any clues of why it is happening?
> > 
> > Thanks in advance,
> > 
> > Rafa
> > 
> > _______________________________________________
> > users mailing list
> > users at gridengine.org
> > https://gridengine.org/mailman/listinfo/users






More information about the users mailing list