[gridengine users] Batch job on interactive queue

Reuti reuti at staff.uni-marburg.de
Fri Jul 1 15:07:21 UTC 2016


Hi,

> Am 01.07.2016 um 17:01 schrieb Jerome <jerome at ibt.unam.mx>:
> 
> Dear Reuti
> 
> Le 29/06/2016 à 16:34, Reuti a écrit :
>> Hi,
> 
>> Am 30.06.2016 um 03:39 schrieb Jerome <jerome at ibt.unam.mx>:
>> 
>> Dear Reuti
>> 
>> Thank's for your answer. I use SGE for a while, and don't realize what you explain here with -now yes ....
> 
> It specifies whether the job must start immediately, or can start at any later point in time (`man qsub`).
> 
> My jobs don't use -now yes, so there will run at any time later.. As that indicate the manual of qsub, -now n is the default for qsub.
> 
>> That's said, my job don't use this option. But, with your comment, I geban to suspect about my PE named "thread", that permits use PE with thread programs. Here is it definition:
>> 
>> # qconf -sp thread
>> pe_name            thread
>> slots              64
>> user_lists         NONE
>> xuser_lists        NONE
>> start_proc_args    /bin/true
>> stop_proc_args     /bin/true
>> allocation_rule    $pe_slots
>> control_slaves     FALSE
>> job_is_first_task  FALSE
>> urgency_slots      min
>> accounting_summary TRUE
>> 
>> I don't really see what in this configuration make that my jobs run in the express queue, that is, act as "-now yes". If i don't use this PE, with on core, the program run in... the default queue all.q . So the problem seems to be in this PE.
> 
> Don't attach the PE to the express.q and it won't run there.Hi,
> 
> That's a do at end. But i can't understand why this issue occurs. Nothing seems to indicate that a job want to run inmediatly when using this PE.

The two settings qtype and pe_list are linked with an OR. If a PE is set in a queue and requested by a job, it may run in this queue and it makes no difference whether qtype is NONE, BATCH or INTERACTIVE or a combination of the two latter ones.

-- Reuti



More information about the users mailing list