[gridengine users] running SOGE/execd on Cygwin

Simon Matthews simon.d.matthews at gmail.com
Fri Oct 20 17:14:44 UTC 2017


On Fri, Oct 20, 2017 at 8:08 AM, William Hay <w.hay at ucl.ac.uk> wrote:
> On Thu, Oct 19, 2017 at 04:49:40PM -0700, Simon Matthews wrote:
>> Does anyone have any pointers on running execd on cygwin?
>>
>> inst_sge -x fails, because the 'uidgid' command doesn't seem to have been built.
>>
>> I can set the environment variables myself and then start the program,
>> but the qmaster doesn't see the execd client. I have disabled the
>> firewall:
>>
>> $ ./CYGWIN_X86/sge_execd.exe
>
> When you say doesn't see it do you mean it is not listed or it is listed
> but the host is uncontactable.  Or to put it another way:  what commands are you
> using to determine that "the qmaster doesn't see the execd client"
> and what is their output?
>
> If the execd is just uncontactable by the qmaster qping might help determine
> whether the execd is responding on the ports it is supposed to.  If it is then you should
> check where the qmaster is looking.
>
> William


What I mean is that the qmaster doesn't see it:
qhost
HOSTNAME                ARCH         NCPU NSOC NCOR NTHR  LOAD  MEMTOT
 MEMUSE  SWAPTO  SWAPUS
----------------------------------------------------------------------------------------------
global                  -               -    -    -    -     -       -
      -       -       -
gw-dev-1l               lx-amd64        8    1    4    8  0.00    7.8G
 487.4M    9.8G     0.0
simon-win764            -               -    -    -    -     -       -
      -       -       -


However, it does appear to be running:
qping simon-win764 6445 execd 1
10/20/2017 10:09:56 endpoint simon-win764.sj.bps/execd/1 at port 6445
is up for 62508 seconds
10/20/2017 10:09:57 endpoint simon-win764.sj.bps/execd/1 at port 6445
is up for 62509 seconds
10/20/2017 10:09:58 endpoint simon-win764.sj.bps/execd/1 at port 6445
is up for 62510 seconds


Simon



More information about the users mailing list