[gridengine users] install_qmaster issue

Jerome jerome at ibt.unam.mx
Thu Apr 19 22:55:07 UTC 2018


Hi Arnau

Le 19/04/2018 à 02:50, Arnau a écrit :
> Hi,
> 
> why don't you first install all dependecies and the sge?
> I don't know what's wrong with your apt, but in mycase apt install -f
> does not want to remove sge.

That the principle of Debian, all deb should install with all
dependencies. That's why i'm a user of debian from more that 20 years ;-)

What i can't realize is that you could install sge in debian 9.4, as the
dependencie od sge is that:

 dpkg -I sge_8.1.9_amd64.deb
 new debian package, version 2.0.
 size 8780400 bytes: control archive=3852 bytes.
    1431 bytes,    31 lines      control
    5751 bytes,    86 lines      md5sums
     135 bytes,     7 lines   *  postinst             #!/bin/sh
     132 bytes,     7 lines   *  postrm               #!/bin/sh
      17 bytes,     1 lines      shlibs
 Package: sge
 Version: 8.1.9
 Architecture: amd64
 Maintainer: Dave Love <sge-bugs at liv.ac.uk>
 Installed-Size: 56370
 Depends: libc6 (>= 2.17), libdb5.3, db5.3-util, libhwloc5 (>= 1.10.0),
libice6 (>= 1:1.0.0), libjemalloc1 (>= 2.1.1), libmunge2 (>= 0.5.8),
libpam0g (>= 0.99.7.1), libsm6, libssl1.0.0 (>= 1.0.0), libtinfo5,
libx11-6, libxext6, libxm4 (>= 2.3.4), libxt6, sge-common, procps, xterm
 Recommends: sge-doc

And the problem is with "libssl1.0.0", There is uniquely libssl1.0.2, as
you have istalled on your own server.
If i force the instalation, i've got a this warning:


dpkg: sge: dependency problems, but configuring anyway as you requested:
 sge depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0 is not installed.

That's normal, the library libssl1.0.0 not existe yet on debian 9.4.

the binaries needs "libssl.so.1.0.0" :

$ ldd /opt/sge/utilbin/lx-amd64/gethostname
	linux-vdso.so.1 (0x00007ffd94446000)
	libmunge.so.2 => /usr/lib/x86_64-linux-gnu/libmunge.so.2
(0x00007f72b8093000)
	libssl.so.1.0.0 => not found
	libcrypto.so.1.0.0 => not found
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f72b7e8f000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f72b7b8b000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0
(0x00007f72b796e000)
	libjemalloc.so.1 => /usr/lib/x86_64-linux-gnu/libjemalloc.so.1
(0x00007f72b7737000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f72b7398000)
	/lib64/ld-linux-x86-64.so.2 (0x00007f72b8511000)

I've change of repository, using the debian oficial one. No matter, the
same error occurs.


> 
> cloud or not cloud should not make any difference.
> I'm attaching the list of installed packages in my system.

Yes, that correct, that's just a joke because i can't install SGE :-(


No problem, thank's for your help. I think i will let it because the sge
will to be unused in a short time, nobody seems to be on charge of it .
Regards!

-- 
-- Jérôme
La crise d'hier est la blague de demain.
	(Herbert George Wells)



More information about the users mailing list