[gridengine users] qsh not working

Friedrich Ferstl fferstl at univa.com
Wed Nov 20 13:21:49 UTC 2019


This person was at the Smithsonian until very recently and shows up in our support records but he is now CFA/Harvard, apparently, using open source.


> Am 19.11.2019 um 23:41 schrieb Korzennik, Sylvain <skorzennik at cfa.harvard.edu>:
> 
> While qrsh and qlogin works fine, qsh fails on
> % qsh
> Your job 2657108 ("INTERACTIVE") has been submitted
> waiting for interactive job to be scheduled ...
> Could not start interactive job (could be some network/firewall related problem)
> 
> from the same prompt/login node, I can
> % ssh -X compute-64-16 /usr/bin/xterm
> or
> % ssh -Y compute-64-16 /usr/bin/xterm
> but not
> % ssh compute-64-16 /usr/bin/xterm
> 
> I do not want to run these 'out-of-band'. I use ssh -Y in the conf (qconf -sconf), yet it fails and I can trace this to:
> 
> 11/19/2019 17:18:19.296800 [10541:143099]: closing all filedescriptors from fd 0 to fdmax=1024
> 11/19/2019 17:18:19.296828 [10541:143099]: further messages are in "error" and "trace"
> 11/19/2019 17:18:19.299121 [10541:143099]: now running with uid=10541, euid=10541
> 11/19/2019 17:18:19.299172 [10541:143099]: execvp(/usr/bin/xterm, "/usr/bin/xterm" "-display" "localhost:15.0" "-n" "SGE Interactive
>  Job 2657108 on compute-64-16.cm.cluster in Queue qrsh.iq <http://qrsh.iq/>" "-e" "/bin/csh")
> 11/19/2019 17:18:19.303787 [446:143093]: wait3 returned 143099 (status: 256; WIFSIGNALED: 0, WIFEXITED: 1, WEXITSTATUS: 1, WTERMSIG: 0)
> 11/19/2019 17:18:19.303843 [446:143093]: job exited with exit status 1
> 11/19/2019 17:18:19.303872 [446:143093]: reaped "job" with pid 143099
> 11/19/2019 17:18:19.303893 [446:143093]: job exited not due to signal
> 11/19/2019 17:18:19.303914 [446:143093]: job exited with status 1
> 
> What magic is needed for the GE to start xterm right? Is this some xauth problem?
> 
>   Thanks,
>     Sylvain
> --
> _______________________________________________
> users mailing list
> users at gridengine.org
> https://gridengine.org/mailman/listinfo/users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://gridengine.org/pipermail/users/attachments/20191120/a41d275f/attachment.html>


More information about the users mailing list